DNS on Cisco Routers – FlackBox

Простая начальная настройка маршрутизатора cisco

В этой статье описывается начальная настройка маршрутизатора Cisco на примере модели 2610. Давайте начнем

Подключение к сети.

Используйте адаптер DB-9 для подключения к консольному порту маршрутизатора. DB-9 – это адаптер для com-порта нашего рабочего компьютера; кабель обычно синего цвета. Порт консоли, расположенный на задней панели устройства и имеющий название Console, обычно маркируется как потребительский.

Все настройки на компьютере изменяются с помощью стандартного терминала; в Windows это HyperTerminal или любая другая программа для входа в SSH и Telnet.

Мы настроили программу на использование значений по умолчанию: 9600 бод, 8 бит данных и отсутствие проверки или мониторинга передачи.

Связь…

Мы отвечаем “Нет” на вопрос, хотим ли мы открыть “Диалог конфигурации системы”.

Если все сложится, мы ждем команду:

Router>

Краткое объяснение системы ввода справки Cisco IOS может быть полезным: просто выбрать “для справки”? Команды могут быть сокращенными (как в unix), но с добавлением оригинального названия, если я не могу вспомнить синтаксис или команду.

Начинаем ввод комманд…
Для настройки входим в привилегированный режим EXEC:
Router>enable
Router#

Если у мы хотим стереть имеющуюся конфигурацию из флеш-памяти, то удаляем ее и перезагружаем устройство:
Router#erase startup-config
Router#reload

Если же у нас уже новая и чистая конфигурация, то начинаем настройку – переходим в глобальный конфигурационный режим:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

Для начала дадим роутеру имя:
Router(config)#hostname R1
R1(config)#

Отключим управление нашим роутером через http и https, а также протокол Cisco Discovery Protocol, который нам в данном случае абсолютно не нужен.
R1(config)#no ip http server
R1(config)#no ip http secure-server
R1(config)#no cdp run

Отключим сервис преобразования доменных имен, чтобы исключить задержки при обработке не правильно введенных команд. По умолчанию маршрутизатор пытается перевести любое значение в командной строке не являющееся командой в адрес(например “Translating «cong»…domain server (255.255.255.255)”). Т.е. при случайной ошибке в имени команды, ввод приходит к замиранию в работе на некоторое время. А нам сейчас это не нужно, отключаем:
R1(config)#no ip domain-lookup

Вернемся к безопасности, сейчас к паролям. Включим сервис шифрования паролей:
R1(config)#service password-encryption

Можно установить минимальную длину паролей, например в 10 символов:
R1(config)#security password min-length 10

Поставим пароль на вход в привилегированный режим, например “ciscoenpass” :
R1(config)#enable secret ciscoenpass

:/>  Windows 10 требует пароль администратора

Далее добавим локального пользователя “ADMIN” с паролем “admin12345”:
R1(config)#username ADMIN  password admin12345

И защитим консольное подключение, вход только для наших ранее введенных локальных пользователей:
R1(config)#line con 0
R1(config-line)#login local
R1(config-line)#exit

И тоже самое на подключение telnet-ом:
R1(config)#line vty 0 4
R1(config-line)#login local
R1(config-line)#exit

Конечно, вы могли бы использовать более полезный метод аутентификации AAA. Но это уже другая история.

Помните, что для проверки вы должны выйти из системы и попытаться войти в систему как наш новый пользователь.

Может быть полезным ограничить время работы при простоях в привилегированном режиме EXEC, например в 5 минут. Это нужно выполнить для всех линий, т.е. для console и vty:
R1(config)#line vty 0 4
R1(config-line)#exec-timeout 5 0
R1(config-line)#exit

В качестве обеспечения безопасности можно еще использовать функцию полного блокирования доступа к устройству в течение, например 120 секунд, после 5 неуспешных попыток аутентификации в течении 60 секунд. Это осуществляется командой, если версия IOS выше 12.4)
R1(config)#login block-for 120 attempts 5 within 60

Ну и конечно, можно настроить доступ по SSH – Secure Shell, безопасный протокол передачи данных по сети.
Генерируем ключи:
R1(config)#crypto key generate rsa 1024
Указываем тип трафика для VTY линий:
R1(config)#line vty 0 4
R1(config-line)#transport input ssh
R1(config-line)#exit

Поднимем интерфейсы.
Например FastEthernet 0/1 это у нас локальная сеть 192.168.1.0, даем первый сетевой адрес и включаем этот интерфейс:
R1(config)#interface FastEthernet 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

На FastEthernet 0/2 у нас внешняя сеть :
R1(config)#interface FastEthernet 0/2
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

Можно настроить статическую маршрутизацию например на следующий маршрутизатор с известным адресом 172.16.1.2 (можно просто использовать интерфейс fa0/2)
R1(config)#ip route 192.168.1.0 255.255.255.0 172.16.1.2

R IP, EIGRP и OSPF являются основой динамической маршрутизации. Но это уже совсем другая история.

Ну и теперь можно посмотреть конфигурацию, что получилось:
R1#show running-config

Если все хорошо, то можно и записать эту конфигурацию в стартовую и перезагрузить маршрутизатор:
R1#copy running-config startup-config
R1#reload

Это все, что я смог придумать для фундаментальной настройки маршрутизатора.

Dns on cisco routers configuration example

Этот пример конфигурации взят из моего бесплатного “Лабораторного руководства Cisco CCNA”, которое содержит более 350 страниц лабораторных заданий и подробные инструкции по настройке лаборатории на вашем ноутбуке, не потратив ни цента.

Для получения бесплатной копии руководства по лабораторным работам Cisco CCNA нажмите здесь.

:/>  Драйвер принтера недоступен в Windows 10 - Технологии Blogger

Мы используем серверное устройство Packet Tracer в качестве DNS-сервера, поскольку маршрутизаторы не могут служить DNS-серверами в Packet Tracer, так как он не поддерживает команду ‘ip dns server’.

Хост с IP-адресом 10.10.10.10 настроен как DNS-сервер и может отвечать на запросы “R1”, “R2” и “R3”.

Нет активного доменного имени.

  1. Настройте R1, R2 и R3 на использование 10.10.10.10 в качестве DNS-сервера. Вам не нужно настраивать имя домена или список доменов.

R1(config)#ip domain-lookup

R1(config)#ip name-server 10.10.10.10

R2(config)#ip domain-lookup

R2(config)#ip name-server 10.10.10.10

R3(config)#ip domain-lookup

R3(config)#ip name-server 10.10.10.10

2. Проверьте, что вы можете пинговать R2 и R3, используя их имена хостов, “R2” и “R3”, с R1 (DNS-серверу может потребоваться некоторое время, чтобы разрешить DNS-запрос).

R1#ping R2

Translating “R2″…domain server (10.10.10.10)

Для отмены введите последовательность escape.

Dns on cisco routers video tutorial

Например, чтобы использовать LinuxA в качестве DNS-клиента, вы можете захотеть пинговать его с маршрутизатора. Чтобы DNS-трафик проходил через маршрутизатор, нет необходимости настраивать его как DNS-клиент. Делайте это только в том случае, если вам требуется, чтобы маршрутизатор мог преобразовывать FQDN в имена хостов.

Router dns commands

При работе с маршрутизатором часто используются IP-адреса. Если вы хотите, чтобы маршрутизатор мог разрешать имена хостов, необходимо ввести следующие команды:

  • Ip domain-lookup: Эта команда позволяет искать DNS-сервер
  • Ip name-server
  • Ip domain-name
  • Ip domain-list : Эта команда используется для поиска дополнительных DNS-поисков

Если вы хотите, чтобы маршрутизатор выполнял функции DNS-сервера, введите эти команды в конфигурацию DNS-клиента вместе со следующими командами:

  • Ip dns server: Эта команда настраивает его как DNS-сервер.
  • Ip host : Эта команда вводит записи адресов для всего, что вы хотите, чтобы она могла разрешить.

Обычно вы не хотите, чтобы маршрутизатор Cisco выполнял функции DNS-сервера. Для этого обычно используется внешний сервер Windows, Unix или Linux.

Как видно из приведенного ниже примера, у меня есть три маршрутизатора: R1, R2 и R3. IP-адрес R1 – 10.10.10.1. IP-адрес R2 – 10.10.10.2, а номер его интерфейса – 10.10.20.2. R3 находится по адресу 10.10.20.1.

R3 будет настроен для работы в качестве DNS-сервера. Чтобы он мог их разрешать, я также настрою на нем записи для всех трех маршрутизаторов. Далее, R1 будет настроен на работу в качестве DNS-клиента.

Сначала настроим DNS-сервер, которым является R3. Я выполню команду “show ip interface brief”, чтобы быстро проверить IP-адреса. Мы будем использовать 10.10.20.1 в качестве нашего DNS-сервера. Я введу первую команду, ip domain-lookup, в режиме глобальной конфигурации, чтобы заставить его использовать DNS.

:/>  Как установить значок язык на рабочий стол

Команда ip name-server используется для настройки местоположения следующего сервера DNS. Это будет 10.10.20.1, то есть сам по себе. Затем я использую команду ip domain-name для настройки доменного имени. Для этого примера я буду использовать flackbox.lab. Затем будет введена команда ip dns server, чтобы сделать этот сервер DNS. Наши инструкции будут следующими:

Поиск домена ip

10.10.20.1 – это IP-сервер имен.

I P-адрес flackbox.lab

Сервер ip dns

Итак, это мои основные команды DNS. Затем необходимо ввести адреса хостов, которые я хочу разрешить. Первым будет R1, расположенный по адресу 10.10.10.1, затем R2 и R3 по адресам 10.10.10.2 и 10.10.20.1, соответственно. Соответствующая команда выглядит следующим образом:

I P-адрес: 10.10.10.1

R2 IP-адрес 10.10.10.2

R3 IP-адрес: 10.10.20.1

Они также будут введены как FQDN. Инструкции будут следующими:

ip host R1.flackbox.lab 10.10.10.1

ip host R2.flackbox.lab 10.10.10.2

ip host R3.flackbox.lab 10.10.20.1

Для моего DNS-сервера это вся необходимая конфигурация. Давайте настроим R1 в качестве DNS-клиента. Чтобы разрешить R1 использовать DNS-сервер, я перейду в режим глобальной конфигурации и введу команду ip domain-lookup. Затем я выполню команду ip name-server, чтобы указать местоположение DNS-сервера. Это относится к R3 по адресу 10.10.20.1. Наконец, я скажу ip domain-list flackbox.lab для DNS-суффикса.

Поиск домена ip

I P-сервер имен

ip domain-list flackbox.lab

Теперь я использую команду end, чтобы вернуться к приглашению enable, а затем давайте проверим, могу ли я теперь разрешать имена хостов на R1. Поэтому я попытаюсь выполнить ping R3, используя его имя хоста, ping R3, чтобы проверить, разрешается ли оно на сервере домена по адресу 10.10.20.1.

It then resolved that and the success rate was five out of five. That looks all good. Let’s also try pinging R2, ping R2. So this will also be resolved by the DNS Server at 10.10.20.1, and it resolved that to 10.10.10.2. I was able to ping that too.

Оставьте комментарий

Adblock
detector