csf ac cmd flood detected | Все о Windows 10

Csf ac cmd flood detected | все о windows 10

Текущая версия: 1.18.3
Дата обновления: 28.06.2009
Анти-чит без клиентской части (Плагин для AMXX)

Требуемые модули:
Cstrike
Engine
Fakemeta

Обнаруживает и блокирует:
— Fast Fire [Быстрая стрельба]
— Speed Hack [Увеличение скорости игрока]
— Spin Hack [Кружение вокруг своей оси]
— CDHack [Cheating Death Hack]
— Fighter FX [Некоторые виды]
— Name Spam [Частое изменение ника]
— Bunny Hop Script [Скрипт распрыжки]
— Cheat Say [Блокирует сообщения в чате от чит-программ]
— Cheat Names [Блокирует читерские ники]
— Cheat List [Блокирует 8 видов читов]

— EcstaticCheat
— TeKilla
— MicCheat
— AlphaCheat
— PimP
— LCD
— Chapman
— PRJVDC

Дополнительная защита:
— Cvar Guard [Запрещает менять определенные консольные команды]
— Zone Guard [Блокировка зон (Выход за пределы игровой зоны)]
— FlashBug Guard [Блокирует Flash баг зоны]
— Anti-Cheat Key [Блокирует нажатие чит-клавиш (END, INS, F12. )]
— Anti-Silent Plant [Убирает беззвучную установку бомбы]
— Anti-Silent Run aka Double Duck [Запрещает бесшумный бег]
— Anti-Fast Pistol Shots [Запрещает использовать скрипты повышающие скорость стрельбы из пистолета]

Дополнительные возможности:
— My Punishment [Позволяет использовать свой плагин для наказания/блокировки читера]
— Два типа обнаружения CDHack,FFX
— Два типа блокировки Silent Run aka Double Duck
— Меню Zone Guard для лёгкого добавления / настройки запрещенных зон

Админские команды:
csf_ac_zoneguard_menu — Вызов меню Zone Guard, для добавления / редактирования запрещенных зон

Локализация:
— Русский Язык
— English Language
— Українська Мова

Папка анти-чита: addonsamxmodxconfigscsf_anticheat
Папка хранения FlashBug зон: csf_flashbug_zones
Папка хранения Блокируемых зон: csf_zone_guard
Основной файл конфигураций античита #1: csf_ac_main.cfg
Основной файл конфигураций античита #2: csf_ac_main2.cfg
Список запрещенных клавиш: csf_ac_cheatkey.cfg
Список запрещенных сообщений: csf_ac_cheatsay.cfg
Список заблокированных консольных команд: csf_ac_cvarguard.cfg
Список читерских ников / клантегов: csf_ac_cheatnames.cfg
Плагин: addonsamxmodxpluginscsf_anticheat.amxx
Файл языка: addonsamxmodxdatalangcsf_anticheat.txt

v1.18.3 (28.06.2009)
— Убран CVAR на звуковое оповещение при обнаружении BHOP, теперь этот параметр неизменный
— Добавлен режим обычной блокировки BHOP, без наказания и звукового оповещения
— Добавлено звуковое оповещение при обнаружении FlashBug
v1.18.2 (26.06.2009)
— Исправил блок зону на карте (de_dust2)
— Исправлен баг с ложным обнаружением FastFire
— Поправлен код, убран лишний участок, который использовался для тестов
— Добавлен Украинский язык

v1.18.1 (26.06.2009)
— Исправил блок зоны на картах (cs_assault, de_dust, de_dust2, de_nuke, de_aztec)
— Должна быть исправлена ошибка Event_RoundStart (line 2628)
— Исправлена ошибка перевода (При бане SPIN HACK, не отображался язык)
— Исправил ошибки в CFG (Как всегда накосячил)
— Исправил двойное логирование Cheat Say
— Исправил ребинд читерских клавиш админам. Ребиндило админам, даже если включен был иммунитет.

v1.18 (25.06.2009)
— Добавлена защита от Fast Pistol Shots [Данная защита не даст стрелять из пистолета, как из M4A1]
— Добавлена Английская локализация
— Причины банов вынесены в файл языка csf_anticheat.txt
— Оптимизирован код, должен меньше грузить процессор ( Просто обязан )
— Удалил «Блокируемую зону» в cs_assault, из-за которой падал сервер.
— Исправлен косяк с двойным логированием CheatNames и CheatKeys

:/>  Как изменить время отключения экрана в Windows 10

v1.17 (24.06.2009)
— Первый выход в паблик, до этого тестировался на наших серверах

1. Делаем себя Админом !

найдите файл users.ini (. cstrikeaddonsamxmodxconfigs )

найдите в нем строчку «User» «password» «abcdefghijklmnopqrstu» «a»

Первое — ник игрока; Второе — пароль на доступ; Третье — уровень доступа; Четвёртое — флаги.

Пишете свой ник и пароль !

Сохраните и закройте файл.

Далее зайдите в . cstrike в файл autoexec.cfg и исправте эту строчку:
setinfo «_pw» «ВАШ ПАРОЛЬ»
пароль должен быть таким, каким вы его писали в users.ini

Сохраните и закройте файл.

перед конектом к серверу в консоле пишете
setinfo _pw mypassword

2. Ставим доступ на админство нескольким людям.

найдите файл users.ini (. cstrikeaddonsamxmodxconfigs )

добавляем строчку после вашей строчки «User» «password» «abcdefghijklmnopqrstu» «a»

«User» «password» «abcdefghijklmnopqrstu» «a»

«User2» «password» «abcdefghijklmnopqrstu» «a»

«User3» «password» «abcdefghijklmnopqrstu» «a»

Первое — ник игрока; Второе — пароль на доступ; Третье — уровень доступа; Четвёртое — флаги.

Разберём какие уровни доступа, что означают:
a — иммунитет (нельзя кикать, слаит, слэпать, банить)
b — резервация
c — использование комманды amx_kick (кикание)
d — использование комманды amx_ban (бан)
e — использование комманды amx_slay
f — использование комманды amx_map
g — использование комманды amx_cvar
h — использование комманды amx_cfg
i — использование комманды amx_chat и других чат-комманд
j — использование комманды amx_vote и других комманд голосований
k — доступ к комманде sv_password (через amx_cvar)
l — доступ к коммандам amx_rcon и rcon_password (через amx_cvar)
m — настраиваемый уровень А (для дополнительных плагинов)
n — настраиваемый уровень B
o — настраиваемый уровень C
p — настраиваемый уровень D
q настраиваемый уровень E
r — настраиваемый уровень F
s — настраиваемый уровень G
t — настраиваемый уровень H
u — доступ к меню, через комманду amxmodmenu
z — пользователь

csf ac cmd flood detected | Все о Windows 10

Готовый Public сервер CS 1.6. Если Вы хотите поднять свой собственный паблик сервер Counter-Strike 1.6, то эта версия Public’a будет одним из лучших вариантов. Самые основные плагины уже входят в сборку, а server.cfg настроен для полноценной игры.

Этот Public Сервер полностью виден в интернете. Работа основана на два протокола 48/47. Для игры Вам не надо ничего устанавливать. Действуйте по пунктам:
1. Скачайте архив и разархивируйте его.
2. Поменяйте название сервера на свое.
3. Обязательно пропишите себе админку. Не забудьте!

Для запуска сервера, в корневой папке Public Server CS 1.6, есть файл START.bat. Запускается сервер именно этим файлов. Работает на операционной системе Windows.

Как видим, ничего сложного нет. Все уже собрано и готово для игры. Поднимаем свой Public Сервер за несколько минут!

В сборку сервера входят:

Metamod 1.19p32
Amxmodx 1.8.1
Dproto 0.9.87
Mmtimer 1.6

csf_anticheat.amxx — Анти-чит для сервера (без клиентской части).
weaponmenu.amxx — WeaponMenu для выбора оружия. Для вызова прописать в консоле weaponmenu.
inp_medium.amxx — Плагин прописывает рейты для игроков и плюс уменьшает пинг и лаги на сервере.
admin_spec_esp.amxx — Админский плагин для отслеживания читеров. Своеобразный вх для админов.
admins_reload.amxx — Плагин решает проблему с админами на мультипротоколловом (47 48) сервере.
admin_check.amxx — Узнать, есть ли на сервере админ. Проверяется командой /admin
bhpk.amxx — Плагин кикает игрока с сервера за высокий пинг. Настраивается.
statsx_shell.amxx — Красочная статистика на сервер.
simple_wh_blocker.amxx — Блокировка WH. Мини античит.
admin_vgk.amxx — ВИП для админа. В начале раунда все гранаты и броня.
ad_manager.amxx — Сообщения «объявления» в чате (прописываются в файле advertisements.ini)
grab_plus.amxx — Грабер для перемещения игроков и различных предметов на сервере. Осуществляется кнопкой Alt (можно забиндить командой bind alt grab)
deagsmapmanager.amxx — Выбор следующей карты последний раунд. Можно номинировать карты, прописывая их в чат и запускать выбор командой rtv.
hostname_timeleft_rus.amxx — В названии сервера будет указываться время игры на текущей карте.
voteban_rus.amxx — Плагин /voteban — Если админов нет на сервере, то игроки могут номинировать читера на бан и забанить его. Русская версия плагина.
afk_manager.amxx — Кик игрока, если он afk.
game_destroyer.amxx — Плагин для поломки читеру CS. Команда amx_destroy ник игрока.
c4timer.amxx — Показывает таймер до взрыва бомбы.
colored_translit.amxx — Новый чат с различными плюшками.
;endroundmusicmp3.amxx — В конце раунда играет музыка. По умолчанию плагин отключен.
;simpleadminmodels.amxx — Admin модели для администраторов сервера. По умолчанию плагин отключен.

:/>  Как сделать пользователя администратором

de_dust2
de_dust2_2x2
$1000$
$2000$
awp_dust
aim_headshot
aim_aztec
de_go_go_go
35hp_2
aim_ak-colt2
aim_deagle5
awp_india
cs_mansion
cs_pf_aztec
cs_pf_dust
de_inferno_2x2
fy_snow
de_clan_mill
aim_crazyjump
fy_pool_day

Icmp-flood

ICMP-flood – отправка большего числа поддельных icmp-запросов (многим известно как ping). ICMP-пакеты не требуют подтверждения, в отличии от TCP и поэтому трудно отделить мусорный трафик от легитимного.

В случае использования правила “нормально закрытого firewall” никаких дополнительных действий предпринимать не надо – весь icmp-трафик будет отклонен, если он отдельно не разрешен. Чтобы позволить “пинговать” роутер с определенных адресов нужно создать разрешающее правило.

Syn-flood

При атаке типа SYN-flood используется TCP-протокол и его принцип установления сеанса связи. Атакующий посылает поддельные syn запросы на установления соединения. Наш маршрутизатор одобрительно отвечает, но атакующий хост не устанавливает соединение и продолжает слать syn-запросы.

Мы не можем просто блокировать TCP-соединения как это было с icmp и udp т.к это основной сетевой протокол. Но мы можем выявлять и блокировать случаи, когда соединения слишком много.

Udp-flood

UDP-flood схож с icmp-flood в том плане, что его пакеты так же не требуют подтверждения и отсутствует контроль над процессом обмена данными.

Бороться с udp-flood можно так же как и с icmp-flood путем полной блокировки трафика, если это допустимо в ваших условиях. Стоит отдельно отметить, что протокол UDP часто используется в VoIP телефонии. Если вы используете подключение к АТС из интернета, то это необходимо учесть и разрешить подключения на необходимые порты, обычно это порт 5060.

Виды ddos-атак

Рассмотрим более подробно виды DDoS-атак, чтобы понять каким образом настраивать firewall mikrotik.

Защита от syn-flood.

Для защиты конкретно от SYN-flood атак правила настраиваются примерно таким же образом, но нужно будет указать protocol=tcp и tcpflag=syn. То есть правило для переброса в цепочку ddos для дальнейшей обработки будет выглядеть примерно так:

/ip firewall filter
add chain=forward protocol=tcp tcp-flags=syn connection-state=new action=jump jump-target=detect-ddos

:/>  Как убрать экран приветствия в Windows 10 - подробная инструкция

P.S. По-моему тема защиты Mikrotik от DDoS недостаточно подробно рассмотрена в рунете на данный момент. Поэтому жду вопросов, предложений и комментариев от вас.

Обнаружение ddos и защита от атак.

Для настройки firewall Mikrotik на обнаружение и защиты от DDOS-атак взята за основу статья на официальном Wiki Mikrotik.

Для того, чтобы выявить DDoS атаку нам необходимо захватывать все новые соединения и перенаправлять их в отдельную цепочку chain=detect-ddos.

/ip firewall filter
add chain=forward connection-state=new action=jump jump-target=detect-ddos

Далее создаем новую цепочку chain=ddos, в которой для каждой пары хостов “SrcIP:DstIP” разрешаем определенное количество соединений. Для избежания блокирования важных хостов, например DNS-сервер с адресом 192.168.0.1, можно добавить правило, которое будет возвращать соединения с сервером в стандартную цепочку.

/ip firewall filter
add chain=detect-ddos dst-limit=32,42,src-and-dst-addresses/1s action=return
add chain=detect-ddos src-address=192.168.0.1 action=return

Значения, заданные в примере, не являются образцовыми и должны устанавливаться исходя из условий вашей инфраструктуры.

Здесь стоит обратить внимание на параметр dst-limit. Первое значение rate, второе burst. Для burst задано значение 42 и интервал в 1 секунду – это значит, что в течении первой секунды количество соединений может быть увеличено до 42. Значение burst не должно быть меньше rate, потому-что в этом случае правило будет пропускать в первую секунду меньшее количество соединений и по истечении секунды сработает Rate.

Если говорить простым языком, то Burst это одноразовое разрешение на превышение скорости. А превышение скорости не может быть меньше той скорости, которую вы установили как норму – Rate.

Сейчас нам надо обработать те соединения, которые превысили заданные лимиты – их мы добавим в address-list ‘ddoser’ (атакующий) и ‘ddosed’ (атакуемый). Тайм-аут жизни списка 10 минут или определите сами для себя.

/ip firewall filter
add chain=detect-ddos action=add-dst-to-address-list address-list=ddosed address-list-timeout=10m
add chain=detect-ddos action=add-src-to-address-list address-list=ddoser address-list-timeout=10m

Теперь мы можем блокировать хосты ведущие DDoS атаку на основе созданных списков. Сбрасывать пакеты можно в стандартной цепочке firewall таким образом:

/ip firewall filter
add chain=forward connection-state=new src-address-list=ddoser dst-address-list=ddosed action=drop

Либо создать правило в Raw, чтобы отбрасывать пакеты до их маршрутизации и снизить нагрузку на процессор.

/ip firewall raw
add action=drop chain=prerouting dst-address-list=ddosed src-address-list=ddoser

Оставьте комментарий

Adblock
detector